python3安装demjson报错

十点数据 2月前 ⋅ 183 阅读

python3 安装 demjson 2.2.4 出现以下报错

error in demjson setup command: use_2to3 is invalid

由于 demjson 2.2.4 兼容python2和python3,当安装环境为python3时,有一部分代码需要转换 Setuptools从版本58.0.0开始不再支持2to3的builds,所以导致 demjson 2.2.4安装后不再可用, 降级setuptools版本即可解决

pip install --upgrade setuptools==57.5.0

全部评论: 0

    我有话说: